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GETTING STARTED WITH EXPRESSION WEB 2
(updated: 6/23/09)

GETTING AN ACCOUNT WITH A WEB SERVER:

Park’s ITS (Information Technology Services) department provides a web server computer named kidd that you can use for your web programming classes. If you’d like to use kidd for this class, you’ll need to create a personal account on kidd and a password-protected cs321 folder within your account. You will need password protection because if you don’t have it, you will run the risk of someone stealing your homework answers and then you will be severely penalized (even though you are unaware of the other person’s illicit behavior).
To create your password-protected cs321 folder on kidd, go to http://kidd.park.edu. Once there, click on the Request a Web Site link. On the next page, log in. On the next page, select the kidd server. Fill out the form.
Your account might be created immediately or it might take up to four business days. To find out your account’s username and password, go to http://kidd.park.edu/username.aspx. You'll need that information in order to upload your files to the web server and also to view your uploaded web pages over the Internet. If you have questions about Park's web server, contact kidd webmaster Scott Davis at scott.davis@park.edu.
If you’d prefer to not use Park’s web server and you already have an account with an Internet Service Provider (ISP), ask your ISP whether they can provide web-hosting services.
As another alternative, you’re welcome to search for web service providers on your own. You may want to check out this web site to see reviews of free and inexpensive web service providers:

http://100best-free-web-space.com/
No matter what web service provider you choose, you’ll need to obtain this information:

· The URL for the site that will receive your uploaded web files.

· Your web-server home-page folder; this is the folder that contains all of your web site's files and subfolders.

· user name

· password

If you've already applied for a site on Park's kidd web server as described above, then you should know this information as a result of that application process, and it should look something like this:
web site URL: https://kidd.park.edu
home-page folder: your choice
user name: ######@park.edu, where ###### is replaced with your Park ID number.
password: your choice
If you don't yet have an account with a web server, for the purposes of getting through this tutorial right now, you can use a temporary account on Park's kidd web server. Here is the information for kidd's temporary accounts:

web site URL: https://kidd.park.edu
home-page folder: student_a, student_b, … student_z (pick one of the 26 folders)

user name: student_a, student_b, …, student_z (user name = home-page folder name)

password: a_student, b_student, …, z_student (password = reversed user name)
Note:

· If you and other people are doing this tutorial simultaneously, communicate among yourselves so that you choose unique accounts.

· Don't use the temporary accounts for anything other than this tutorial.
· The temporary accounts are periodically wiped clean.

· Uploads to the temporary accounts can be traced to the source, so you will be held accountable for any material that you upload. No hardcore pornography, please.
A home page is a web page that is considered to be a starting point for web navigation. A home-page folder is a folder that contains a home page. If you apply for an account on kidd, you'll be asked for a user name and your user name will be used for your home-page folder. My home-page folder is jdean.

EXPRESSION WEB BACKGROUND INFORMATION:

There are many different ways to upload web page documents to a web server. In this course, you are allowed to use any tools that you like to accomplish these tasks. Since our lab has Expression Web 2, I’ll describe how to use that tool. Although you may use tools other than Expression Web 2 for future homework assignments, you must use Expression Web 2 for this tutorial. You are responsible for knowing how to use Expression Web; i.e., I may ask you questions about it on the exams.

As a member of the MSDN Academic Alliance, Park is allowed to provide Microsoft software to students who are enrolled in at least one computer class. You can obtain a free copy of Expression Web 2 by going to the MSDNAA link on the ICS Department’s web site, http://www.park.edu/ics.
EXPRESSION WEB TUTORIAL:

When doing your homework assignments, you’ll probably want to use this Expression Web tutorial as a guide. It is up to you to carefully reread this Expression Web tutorial and figure out how to do things for your homework assignments.

This tutorial assumes that you are working in the lab. Since you are not allowed to save anything on the hard disks in the lab, the tutorial asks you to create all your files on your USB flash pen, not on your hard disk. Flash pens often use the f: drive, so the tutorial uses the f: drive. If you prefer to use a diskette rather than a flash pen, replace f: with a: throughout the tutorial. If you do this tutorial at home and you'd like to use your hard drive, replace f: with c: throughout the tutorial.

To help with the big picture, here's a summary of what you'll be doing in this tutorial:

· On your local computer:

· Create a web site named cs321.

· Create a tutorial folder within your web site.

· Create a simple hello web page in your tutorial folder.

· Preview your web page.

· On your web server:

· Open up your default web site (or create a new web site if there's no default web site).

· If a 

· In your web-server web site’s cs321 folder, create a tutorial folder.
· Upload your local computer's hello web page using the import command.

· View your web page on the Internet.

· On your local computer:

· Create a copy of your hello web page and name it hello2.html.

· Edit your hello2 web page so that it uses an image file.

· On your web server:

· Upload your local computer's hello2 web page files using the import command.

· Create an images folder.

· Upload your local computer's image file.

· View your hello2 web page on the Internet.

	Actions
	Supplemental Information

	Load Expression Web 2.
	Click on the Start button.

Select Programs.

Select Microsoft Expression Web 2.



	Set coding-style preferences.
	Select Tools / Page Editor Options.

That should cause a Page Editor Options dialog to appear.

Click the Code Formatting tab.

In the Tab size box, enter 2.

In the Indent box, enter 2.

In the characters box, enter Spaces.

Make sure that the Insert tabs as spaces box is checked.

Click OK.



	Create a new web site.
	Click the File menu.

Move your mouse over the New… option.
That should cause a menu to pop up. Select Web Site… from the pop-up menu.

In the New window, the Web Site tab should be pre-selected.

Select the General container and then the One Page Web Site option.
In the location of the new web site box, type f:\cs321.
Click OK.



	What is an Expression Web web site?
	A web site is Expression Web's term for a group of files and folders that can be organized and uploaded using Expression Web's commands. Using a web site, with its ability to work on files and folders as a group, makes things easier for web developers. However, using a web site is certainly not mandatory when it comes to web development. Many web developers use a bare-bones text editor like NotePad to create files, use Windows Explorer to create folders, and use an FTP tool like WS_FTP to upload the files and folders.



	Explore the newly created web site's folder list.
	Your Expression Web window should now contain a Folder List pane (look for the words "Folder List" at the top of the left pane). If there is no Folder List pane, click the View menu and then select Folder List.

The folder list displays the files and folders in your newly created web site.
During the web site creation process, if you specify folders that don't exist, the web site creation process creates the specified folders. In our case, the cs321 folder was created (if it didn’t exist previously).



	Open a file.
	Find the newly created default.html file and double click it.

The default.html file should appear in the right pane as indicated by the default.html heading in the right pane.



	Rename the file.
	In the left pane, right click on the default.html file and select Rename from the pop-up menu.

Enter index.html, and it should overlay default.html.

If you’re asked to confirm the rename operation, click Yes.



	What is index.html?
	The index.html file (or, equivalently, the index.htm file) is the standard file for a web site's home page. It's typically the first page that someone sees when visiting a web site.

Aside: Microsoft’s web server product, IIS, allows not only index.html, but also default.html, to be used as a web site’s home page. To help out the web developer (and to make things difficult for Microsoft’s competition, Apache), Expression Web generates a simple default.html file that can be used as a starting point.



	What are the viewing tabs?
	Note the tabs at the bottom of the index.html pane – Design, Split, and Code. They determine the manner in which the user views the file's contents.
Click on the Design view tab. The Design view shows approximately how the file will be displayed when viewed on the Internet. Since the Design view is blank at this point (right?), that means that your current index.html page will display nothing when viewed on the Internet. Although many web developers (especially new web developers) use the Design view extensively, I require that you refrain from doing so. Got it? Never use Expression Web's Design view!

Click the Code tab.

Note that the Code view shows the actual HTML in the index.html file.

The problem with the Design view is that it allows users to edit the file with Expression Web commands that generate poor HTML code. To compound the problem, the Design view hides HTML code so the user is unaware of the poorly written HTML code that he/she is generating.

More specifically, Design view HTML code tends to be poorly written in that:

· It tends to be unnecessarily verbose (which means large files which means long download times).

· It sometimes does not follow proper HTML coding standards (which can lead to display problems on certain browsers).

· It tends to produce rigid code that doesn't adapt well to varying browsers and browser settings.

 

	For all future homework assignments, use this naming scheme.
	To keep things organized throughout the semester, I'd like you to put your web pages in separate folders. Later on when you learn about links, you'll use index.html files to link your folders and web pages together.

For this tutorial, you'll create two web pages and store them in a folder named tutorial. For homework 1, you'll store web pages in a folder named hw1, for homework 2, you'll store web pages in a folder named hw2, etc. The tutorial, hw1, hw2, etc. folders should all be inside your cs321 folder. For all future homework assignments, use that naming scheme!



	Create a tutorial folder.
	Make sure that the cs321 folder is highlighted in the Folder List pane.

Click on the New Folder icon in the top-right corner of the Folder List pane.
A newly generated folder should appear in your Folder List pane. The name of the new folder is New Folder by default.

You now need to rename the folder to tutorial:

1. If the name New Folder is already selected/highlighted, you should be able to immediately enter tutorial, and it should overlay New Folder.

2. If that doesn’t work, then try clicking on the New Folder icon with the right mouse button. That should cause a menu to pop up. Select Rename from the pop-up menu. Immediately enter tutorial, and it should overlay New Folder.



	Create a new page within the tutorial folder.
	Make sure that the tutorial folder is highlighted in the Folder List pane.

Click on the File menu.

Move your mouse over the New… option and select Page… from the pop-up menu.

In the New window, the Page tab should be pre-selected.

Select the General container and then the HTML option.

Click OK.


	Enter content for the new page.
	Make sure the main window's right pane is in Code view mode.

Delete the entire contents of the right pane (i.e., delete all the code).

Enter this where yourName is replaced with your actual name:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<meta name="author" content="yourName" />

<title>Hello world tutorial</title>

</head>

<body>

Hello, world!
</body>

</html>



	Understand the code.
	Note the following items in the hello.html page:

· The xml element tells the browser the version of XML that's being used and the character set that's being used.

· The DOCTYPE element tells the browser the type of document that's being displayed.

· meta elements are used to help search engines locate relevant web pages.

· The title container's contents should display in the browser's title bar. So, for this hello.html page, the browser will display "Hello world tutorial" in its title bar.

· The body container's contents should display in the browser's content area.



	Save your web page.
	As always, it behooves you to save often. Note that if you edit a web page, you'll be able to preview it without having to save it first. That might lull you into thinking that the page is saved. It's not! If you don't save and you 1) view the page on a browser or 2) upload the page to a web server (explained later), you'll be using the web page's old version, not its new version.

Click the File menu.

Select Save As…
In the folders area, find the tutorial folder and double click on it.
Enter hello.html in the File name box (don't forget to tack on the "l" in the filename extension).

Click Save.



	Preview the page.
	Click on the Split tab.

Hello, world! should be displayed in the bottom of the split window.


	Load a new Expression Web session.
	Click on the Start button. Select Programs. Select Microsoft Expression Web 2.

The goal of the next several steps is to open an Expression Web session for your web server's web site. You’ll then go back and forth between your web server’s web site and your local computer's web site.



	On your web server Expression Web session, open your user name web site and then your cs321 subweb.
	If your web service provider creates a web site for you, then you should perform this step. Since Park's kidd web server does create a default web site for you, those of you using Park's kidd web server should perform this step.

Click the File menu.

Select Open Site…
In the Site name box, enter the URL for your user name web site. For example, to access your user name web site on Park's web server, you would enter https://kidd.park.edu/######, where ###### is replaced with your Park ID number. Note the “s” in https, which stands for “secure socket layer.” It’s OK to omit the s when you load one of your kidd web pages in a browser, but you are required to include the s when you open your kidd site in Expression Web.
Click Open.
You should be prompted to log onto the web server. Enter your user name and password.

In applying for a site on kidd, kidd's webmaster should have automatically created a password-protected cs321 subweb inside your user name web site. Check to see whether that subweb’s cs321 folder exists. If it doesn't exist, contact the kidd webmaster and ask for a password-protected cs321 subweb.

In the folder list, double click on the cs321 folder.

That should generate a new window for your cs321 subweb with cs321 at the root of the subweb’s folder list.



	On your web server Expression Web session, create a new web site and create a cs321 subweb within it.
	If your web service provider does not create a default web site for you, then you should perform this step. Since Park's kidd web server does create a default web site for you, those of you using Park's kidd web server should skip this step.

Click the File menu.

Move your mouse over the New… option.
That should cause a menu to pop up. Select Web Site… from the pop-up menu.

In the New window, the Web Site tab should be pre-selected.

Select the General container and then the One Page Web Site option.

In the location of the new Web Site box, type the URL for your home-page folder on your web server.

Click OK.

You should be prompted to log onto the web server. Enter your user name and password.

In the Folder List pane, select the home-page folder for your new web site.

Click the File menu.

Move your mouse over the New… option.
That should cause a menu to pop up. Select Web Site… from the pop-up menu.

In the New window, the Web Site tab should be pre-selected.

Select the General container and then the One Page Web Site option.

In the location of the new Web Site box, type the URL for your home-page folder plus “/cs321” appended to the right side.

Click OK.

That should generate a new window for your new subweb with cs321 at the root of the subweb’s folder list.


	Create a tutorial subfolder.
	In the Folder List pane, select your cs321 folder.

Create a subfolder named tutorial inside your cs321 folder.



	Open and close folders 
	For practice purposes, click on the + and – icons in the Folder List pane to open and close folders.


	On your web server Expression Web session, upload your local computer's hello.html web page.
	Make sure that your tutorial folder is highlighted in the Folder List pane.

Click on the File menu.

Select Import.

That should cause a menu to pop up. Select File… from the pop-up menu.

In the newly generated Import window, click the Add File… button.
In the File name box, enter f:\cs321\tutorial\hello.html.

Click the Open button.

In the Import window, click on the OK button to initiate the upload process.

Be patient during the upload – it may take several seconds.


	Go to your web page on the Internet.
	Open up a browser and fill in the address field with the web server's main URL, a slash, the path to your cs321 folder, a slash, the tutorial subfolder, a slash, and then the web page filename. For example, I would specify this:

https://kidd.park.edu/jdean/cs321/tutorial/hello.html

If your web site is password-protected, you should be prompted to log in. Enter your user name and password.



	View your uploaded page.
	Hello world tutorial should be displayed in the title bar.

Hello, world! should be displayed in the browser content area.



	Go to your local computer's Expression Web session.


	

	On your local computer's Expression Web session, create a copy of your hello.html file.
	In the Folder List pane, look for your hello.html file.

Right click on your hello.html file and select Copy from the pop-up menu.

In the Folder List pane, look for the tutorial folder.

Right click on the tutorial folder and select Paste from the pop-up menu.

The paste operation should have created a file named something like hello_copy(1).html.



	Rename your copied file to hello2.html.
	You now need to rename the new file to hello2.html:

1. If the new file's name is already selected/highlighted, you should be able to immediately enter hello2.html and it should overlay hello_copy(1).html.

2. If that doesn’t work, then try clicking on the hello_copy(1).html icon with the right mouse button. That should cause a menu to pop up. Select Rename from the pop-up menu. Immediately enter hello2.html and it should overlay hello_copy(1).html. To finalize the rename process, press the return key.

After you press the return key, you may or may not see an "unable to update hyperlinks" message. If you do see it, click on OK to continue.


	Display hello2.html in the edit pane.
	Even though you just created hello2.html, your edit pane doesn't automatically contain its contents. To display hello2.html in the edit pane, double click on the hello2.html file in the Folder List pane.



	Edit your hello2.html page.
	Edit the contents of your hello2.html file so that it contains the following where yourName is replaced with your actual name:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<meta name="author" content="yourName" />

<title>Hello world tutorial</title>

</head>

<body>

Hello,

<img src="../images/earth.gif" width="40" height="40"
  alt="world" />!

</body>

</html>



	Preview the page.
	After saving your hello2.html file, click on the Split tab.

"Hello, *!" should be displayed, where the "*" is replaced with an icon that indicates that the browser can't find the specified item.



	Understand the images folder.
	In your HTML code, note that the img element's src attribute refers to the file ../images/earth.gif. That means that the browser will attempt to find a file named earth.gif. It attempts to find the file by going up to its parent folder (the ".." specifies the parent folder), then going down to an images folder. The earth.gif file should be stored in the images folder.

It is standard practice to have an images folder in a web site’s root folder.

With Expression Web version 2, the images folder appears to be created automatically for web sites on a network, but not for web sites on local storage media. Since you are now working with your flash pen, the images folder is probably missing, and if it is, go ahead and create it within f:\cs321.



	Load earth.gif into the images folder.
	Use a browser to find an earth icon file. I found earth icon files by going to Google’s image library at http://images.google.com.

Once you find an earth icon file on the Web, right click on the picture itself and select Save Image As… for FireFox or Save Picture As… for Internet Explorer. Save the file to f:\cs321\images with the name earth.gif.

Note that you could have saved the file to any folder as long as your img element's src attribute points to it. I'm asking you to use an images folder because that's a standard folder and following standards helps with maintainability.

For all future homework assignments that use image files, you must store image files in an images subfolder that’s inside your cs321 folder. Don't forget!



	Preview the page.
	"Hello, * !" should be displayed, where the "*" is replaced with an earth icon. If the earth icon isn't displayed, try refreshing the view by switching to the Code view and then switching back to the Split view.


	Go to your web server's Expression Web session.


	

	On your web server Expression Web session, upload your local computer's hello web page.
	Make sure that your tutorial folder is highlighted in the Folder List pane.

Using the techniques explained above, use the import command to upload the hello2.html file.


	On your web server Expression Web session, create an images folder.


	Make sure that your cs321 folder web site is highlighted in the Folder List pane.
In your cs321 folder, look for an images folder, and if it’s not there, create it.


	On your web server Expression Web session, upload your local computer's earth.gif file.


	Make sure that your images folder is highlighted in the Folder List pane.

Use the import command to upload the earth.gif file.


	View your web server's hello2.html file on the Internet.


	

	View your uploaded page.
	Hello world tutorial should be displayed in the title bar.

Hello, *! should be displayed in the browser content area, where the "*" is replaced with an earth icon.



	Exit from both Expression Web sessions.


	For each Expression Web window, click the File menu and then select Exit.




